[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Help needed to detect gtest_main (Was: Bug#940327: convert libpbseq-dev to Architecture: any)

Control: tags -1 pending


I wanted to upgrade to the latest upstream version in Git[1] where
upstream has changed the build system.  Its a bit irritating to use
meson on top of cmake (at least I have never seen this before) and I
think I have added all needed Build-Depends (locally - not commited

diff --git a/debian/control b/debian/control
index b4d7424..c5a11fd 100644
--- a/debian/control
+++ b/debian/control
@@ -5,6 +5,10 @@ Section: libs
 Priority: optional
 Build-Depends: debhelper-compat (= 12),
+               meson,
+               pkg-config,
+               cmake,
+               googletest,

Despite I have added googletest it seems not be found:

Library rt found: YES
Configuring LibBlasrConfig.h using configuration
Program tools/check-formatting found: YES (/build/pbseqlib-5.3.3+dfsg/tools/check-formatting)
Pkg-config binary for MachineChoice.HOST is cached.
Determining dependency 'gtest_main' with pkg-config executable '/usr/bin/pkg-config'
Called `/usr/bin/pkg-config --modversion gtest_main` -> 1

CMake binary for MachineChoice.HOST is not cached
CMake binary missing from cross or native file, or env var undefined.
Trying a default CMake fallback at cmake
Trying CMake binary cmake for machine MachineChoice.HOST at ['/usr/bin/cmake']
Found CMake: /usr/bin/cmake (3.13.4)
Extracting basic cmake information
Try CMake generator: auto
Called `/usr/bin/cmake --trace-expand .` in /build/pbseqlib-5.3.3+dfsg/obj-x86_64-linux-gnu/meson-private/cmake_gtest_main -> 0
  -- Module search paths:    ['/', '/opt', '/usr', '/usr/local']
  -- CMake root:             /usr/share/cmake-3.13
  -- CMake architectures:    ['x86_64-linux-gnu']
  -- CMake lib search paths: ['lib', 'lib32', 'lib64', 'libx32', 'share', 'lib/x86_64-linux-gnu']
Run-time dependency gtest_main found: NO (tried pkgconfig and cmake)
Looking for a fallback subproject for the dependency gtest_main

unittest/meson.build:14:0: ERROR: Automatic wrap-based subproject downloading is disabled

I also tried adding libgtest-dev in addition but this does not change
the situation.

Any hint, what to do?

Kind regards


[1] https://salsa.debian.org/med-team/pbseqlib


Reply to: