[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#935900: RFS: z3 4.8.4-0.1 [NMU]

control: owner -1 !
control: tags -1 moreinfo
Hello Fabian,

I tried many times to update it, would you mind pushing your work directly on the pkg-llvm repository?

In the meanwhile I'm having a look at your work

Il martedì 27 agosto 2019, 19:39:28 CEST, Matthew Fernandez <matthew.fernandez@gmail.com> ha scritto:

On Aug 27, 2019, at 08:48, Fabian Wolff <fabi.wolff@arcor.de> wrote:

On 8/27/19 4:00 PM, Matthew Fernandez wrote:
z3 (4.8.4-0.1) unstable; urgency=medium

I am not a z3 dev, but the latest z3 release is 4.8.5. Is there a
particular motivation for uploading a 4.8.4-based release?

Thanks for pointing this out; I did not notice this, because I was
using uscan, and upstream suddenly changed the tag format on Github for
tagging new releases:


Ah, I was not aware of this either, so we both learned something :)

In the last hour or so, I have tried to import version 4.8.5, but they
apparently changed something in the build system so that building with
Mono no longer works (it fails with 'dotnet: Command not found', and I
don't know what the Mono equivalent of the dotnet command is, or if one
exists at all).

I’ve built 4.8.5 before, but not the .net bindings which I guess is what you’re dealing with. I can attempt this but unfortunately won’t have time in the short term.

So, I'd say having version 4.8.4 is still better than 4.4.1, and if
someone else wants to give 4.8.5 another try in the future, they can do
so after this upload.

Agreed. Having 4.8.4 available would be a significant improvement. Thanks!

Reply to: