[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#856792: RFS: jpcre2/10.29.02-1 [ITP: #856780] -- C++ wrapper for PCRE2 library



I want the version to be 10.30.01-2

Latest changes:

* API change.
* Make `initMatch()`a synonym for `getMatchObject()`.
* Make `initReplace()` a synonym for `getReplaceObject()`.
* Improvement to `match()` function.
* Different name for the same group is permitted (deviation from the
PCRE2 spec 10.21):
* Implement move constructors and move-assignment operator.
* Guard against null pointer with well defined behavior.
* Rename confusing name `setMatchData()` to `setMatchDataBlock()`.
* Add `MatchEvaluator::resetMatchData()`
* Add `clear()` functions to each class.
* Remove `Regex::initMatchFrom()` and `Regex::initReplaceFrom()`.
* Remove `Regex::match()` and `Regex::replace()` without any argument.
* Add `ModifierTable` class for creating custom modifier tables.
* PCRE2 compatible `replace()` function to take MatchEvaluator.
* Match data re-usability by MatchEvaluator.



Attachment: signature.asc
Description: OpenPGP digital signature


Reply to: