[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#667904: RFS: mitlm/0.4-1 [ITP] -- MIT Language Modeling toolkit



Il 02/01/2013 23:33, Jakub Wilk ha scritto:
> * Giulio Paci <giuliopaci@gmail.com>, 2013-01-02, 01:40:
>>> dh_shlibdeps -plibmitlm0
>>> dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/libmitlm0/usr/lib/libmitlm.so.0.0.0 was not linked against libquadmath.so.0 (it uses none of
>>> the library's symbols)
>>
>> This warning is still there, but I do not know how to remove it. In this case -Wl,--as-needed did not work.
>> libquadmath linking is added by the autoconf check for gfortran, used to compile part of the library. Do you have any hints?
> 
> I guess we're running into #347650 here.

I think you are right.

> If it's too burdensome to implement a work-around for it, I think we can live with this useless dependency...

As the problem comes from autoconf, I disabled the check for the fortran libraries by explicitly setting FLIBS="-lgfortran -lm" environment variable.
The warning is gone.

Bests,
	Giulio.


Reply to: