[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#690188: RFS: apt-fast/1.7.6-1 ITP

Package: sponsorship-requests
Severity: wishlist

Dear mentors,

I am looking for a sponsor for the package "apt-fast".

 * Package name    : apt-fast
   Version         : 1.7.6-1
   Upstream Authors: Matt Parnell, Dominique Lasserre
 * URL             : https://github.com/ilikenwf/apt-fast.git
 * License         : GPL-3+
   Section         : admin

It builds a single binary package:
  apt-fast   - shellscript wrapper for apt-get or aptitude

To access further information about this package, please visit the
following URL:

Alternatively, one can download the package with dget using this command:
  dget -x

The packaged apt-fast comes with debconf interface, meaning you can
configure all those 7 configuration options on installation time (or
just edit config file manually). This is done with Perl. Package doesn't
depend on it explicitly because only builtins from essential perl-base
are used.
debconf dialogs are translated (fully) in 17 and (partially) in 19
languages. Translation is done on Launchpad:

Two manpages are provided (apt-fast itself (8) and config file (5)) (no

Bash and Zsh autocompletion is included. They are derived from
distributed apt (apt-get) completions (bash: Ubuntu 10.04 to make it
backwards compatible; zsh: current unstable).

There is no upstream build system, so installation is simply c&p of
relevant files (apt-fast itself has only ~320 lines of code).

You'll find further information on Github homepage (see above) and
Launchpad project:

I would be glad if someone take a look at this package. :)

Dominique Lasserre

Attachment: 0xB2E4F4F3.asc
Description: application/pgp-keys

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: