[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#676114: Ruby help needed (Was: Bug#676114: wordnet: FTBFS: debian/wn-for-goldendict.rb:465: invalid multibyte char (US-ASCII))

On Tue, Jun 05, 2012 at 07:24:00PM +0200, Andreas Tille wrote:
>Hi Steve,
>On Tue, Jun 05, 2012 at 06:10:55PM +0100, Steve McIntyre wrote:
>> >Any better hint?
>> It sounds like you should replace the functionality of the script in a
>> more suitable language, specifically:
>>  * one you (and other maintainers) understand
>>  * one that's stable and supported on all the platforms in Debian
>> At the moment, that doesn't sound like Ruby. :-(
>Yes.  I asked Dmitry to choose a different language when he introduced
>this into the packaging to create an additional binary package.
>However, at this time Dmitry volunteered to care for this (and up to
>know he did so).  If this support would stop my solution would be to
>drop the additional binary package (and thus goldendict support) because
>I (as the only active maintainer out of the team) can not support this.

Sounds like you made a mistake, I'm afraid. :-(

This is a general problem that might be shared usefully with a wider
audience - developers should try hard to *not* write build scripts or
maintainer scripts in their favourite language-of-the-week. It makes
packages that much harder to maintain in general, whether within the
existing team, replacement maintainers, the QA team, etc...

Steve McIntyre, Cambridge, UK.                                steve@einval.com
"You can't barbecue lettuce!" -- Ellie Crane

Reply to: