[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

help with intra-package dependencies (library and binary)


I'm trying to package 'lhasa' but I'm having some trouble. There is a binary
package 'lhasa' shipping a binary which depends on a library from a library
package 'liblhasa0', all from the same source. (analogous to curl depending
on libcurlX from the same source package)

My packaging is at https://github.com/jmtd/tmp-dpkg-lhasa and the orig tarball
can be obtained either via pristine-tar and some magic incantations from that
repo or at <http://fragglet.github.com/lhasa/>. I've just pushed the latest
version to mentors and will reply with a URL once I have it.

The issue, quite simply, is dpkg-shlibdeps bails out when investigating the
'lhasa' binary. Full build log at https://github.com/jmtd/tmp-dpkg-lhasa/issues/1,
the pertinent error is

> dpkg-shlibdeps: error: couldn't find library liblhasa.so.0 needed by debian/lhasa/usr/bin/lha (ELF format: 'elf64-x86-64'; RPATH: '').
> dpkg-shlibdeps: error: Cannot continue due to the error above.
> Note: libraries are not searched in other binary packages that do not have any shlibs or symbols file.
> To help dpkg-shlibdeps find private libraries, you might need to set LD_LIBRARY_PATH.
> dh_shlibdeps: dpkg-shlibdeps -Tdebian/lhasa.substvars debian/lhasa/usr/bin/lha returned exit code 2

I've tried reading maint-guide, dpkg-shlibdeps(1), dh_shlibdeps(1) and the source
for the zlib and curl packages to no avail.  I've tried providing a shlibs file
containing just

> liblhasa 0 liblhasa0(>= 0.0.4-1)

no luck. I've found the shlibs documentation fairly impenetrable.  I haven't
attempted to provide a symbols file, I thought that was overkill at this stage,
but perhaps that's the missing link?

Any pointers much appreciated.

Reply to: