[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: googlizer (updated package)



Hi,

> I am looking for a sponsor for the new version 0.3-4
> of my package "googlizer".
> 
> It builds these binary packages:
> googlizer  - utility to search Google via your GNOME menu/panel
> 
> The package appears to be lintian clean.
> 
[...]

That might well be, but it fails to build:

gcc -lgtk-x11-2.0 -lglib-2.0 -lgnome-2 -lgnomeui-2 -Wl,--no-add-needed -Wl,--as-needed `pkg-config --libs libgnomeui-2.0 libgnome-2.0 gtk+-2.0 glib-2.0` googlizer.o -o googlizer
/usr/bin/ld: /usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../../../lib/libgtk-x11-2.0.so: undefined reference to symbol 'gdk_atom_intern'
/usr/bin/ld: note: 'gdk_atom_intern' is defined in DSO /usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../../../lib/libgdk-x11-2.0.so so try adding it to the linker command line
/usr/lib/gcc/x86_64-linux-gnu/4.6.1/../../../../lib/libgdk-x11-2.0.so: could not read symbols: Invalid operation

Besides this fundamental problem, please also consider the using the simplified
debian/rules file as you upgrade to debhelper >= 7. Another plus would be moving
debian/copyright to DEP-5 format.

Thanks a lot,
Michael

Attachment: pgpuW7SExqTwr.pgp
Description: PGP signature


Reply to: