[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ${xviddriver:Provides} broken?

On 2011-02-22 23:08 +0100, Harald Dunkel wrote:

> On 02/22/11 21:29, Sven Joachim wrote:
>> Are you using xsfbs?  If so, this is probably because the
>> /usr/share/xserver-xorg/videoabiver file is gone.
>>> instead of
>>> 	xserver-xorg-video-6.0
>>> or
>>> 	xserver-xorg-video-8.0
>>> How comes? Any helpful comment would be highly appreciated.
>> You should just provide xserver-xorg-video and not any particular ABI.
>> In xserver-org-dev 2:1.9.4-1 and later, dh_xsf_substvars will expand
>> "${xviddriver:Provides}" accordingly.
> I have  xserver-xorg-dev 2:1.9.4-3 installed, so instead of "xserver-xorg-video-"
> it should have set "xserver-xorg-video", right?

If you are using dh_xsf_substvars.  But I suspect you don't, and
${xviddriver:Provides} gets expanded by a makefile snippet in your
source tree instead which tries to read a non-existent file.

> The ${xinpdriver:Provides} seems to have the same problem.

Quite possible.

> Bug report?

Not without seeing the source of your package.


Reply to: