[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Manual usage of quilt does not work any more


I'm currently totally clueless in the following situation:  I took
a random package I'm maintaining (at least it is the case for three
totally unrelated packages), say texmaker.  I obtained the source
tarball, untarred it and copied the debian/ dir from SVN into it.
Then I tried:

/tmp/texmaker/texmaker-2.2.1$ quilt push
Applying patch 10_spelling_dict.patch
patch: unrecognized option '--unified-reject-files'
patch: Try `patch --help' for more information.
Patch 10_spelling_dict.patch does not apply (enforce with -f)

I have no idea at all why the patch does not apply because

/tmp/texmaker/texmaker-2.2.1$ patch -p1 < debian/patches/10_spelling_dict.patch 
patching file configdialog.cpp

works perfectly fine.  If I unpack the source via

/tmp/texmaker$ dpkg-source -x texmaker_2.2.1-1.dsc 
dpkg-source: info: extracting texmaker in texmaker-2.2.1
dpkg-source: info: unpacking texmaker_2.2.1.orig.tar.bz2
dpkg-source: info: unpacking texmaker_2.2.1-1.debian.tar.bz2
dpkg-source: info: applying 10_spelling_dict.patch
dpkg-source: info: applying spelling-error-in-binary.patch

the patches are applied, however I can not unpatch:

/tmp/texmaker/texmaker-2.2.1$ quilt applied

/tmp/texmaker/texmaker-2.2.1$ quilt pop -a 
Patch spelling-error-in-binary.patch does not remove cleanly (refresh it or enforce with -f)

The hint for refreshing or enforcing with -f is not helpful at all.

My ~/.quiltrc is

QUILT_DIFF_ARGS="--no-timestamps --no-index"
QUILT_REFRESH_ARGS="--no-timestamps --no-index"

and I'm observing this problem on two different boxes both with nearly
up to date testing (last update two days ago).  I also tried the same in
an up to date unstable chroot on a third computer.  Everything with the
same result.

The problem is that I'm simply unable to move forward and backward in
the patch set because neither starting from an unpatched source nore
from a patched source seems to work any more.  As I said this is
the case with any package I tested and I neither can believe what I
see nor do I have the slightest idea what change might have caused this

Any help would be really welcome



Reply to: