[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: embedded-zlib and fpc

Am 13.04.2010 23:14, schrieb Russ Allbery:
Patrick Matthäi<pmatthaei@debian.org>  writes:
Am 13.04.2010 06:55, schrieb Raphael Geissert:
Patrick Matthäi wrote:

There is also an lintian error, which can not be overwritten and would
reject it from the repository:
E: easymp3gain-gtk: embedded-zlib ./usr/bin/easymp3gain

This is added by fpc, see #472304. Not sure what the real status is, though.

@ftp-masters: was the removal of embedded-zlib from the list of tags
that can be overridden just temporary (because of the klibc incident)?

A new version of lintian is about to be released and would like to know
whether that change should be propagated.

I think raising the severity of the bug to a RC-one would be a good
idea, because this prevents packages built with fpc to get uploaded into
the archive.

Another possible solution would be, to allow again the embedded-zlib,
until this bug has been fixed.

That bug looks unrelated to embedded-zlib.  It's about statically linking
with Pascal libraries included in FPC.

The problem with embedded-zlib appears to be a false positive in Lintian.
It seems to be triggering on the string:

     "Seek in deflate compressed stream failed."

although I don't see how that would match the regex that Lintian is using.
I can't find any other occurance of "inflate" or "deflate" in the strings
for easymp3gain, though.

You should override this Lintian tag for right now until we can figure out
what's going on.

But this one is one of the not-overrideable-ones as in: the package will be rejected.

Reply to: