[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

ia32-apt-get: Striking my colors


I'm striking my colors. By popular demand I'm orphaning the ia32-libs
and ia32-libs-gtk transitional packages. As said before the
prerequisite for that was that someone else steps up as new maintainer
for the old ia32-libs and ia32-libs-gtk monsters and Mark Hymers has
agreed to do so. I don't know if Bdale Garbee <bdale@gag.com> and
Frederik Schüler <fs@debian.org> will remain co-maintainer that is up
to them.

I've have prepared a new version (22) of ia32-lib-tools


- drops ia32-libs and ia32-libs-gtk packages so Mark can take them
- removes all diversions to the package management
- adds a conflict with ia32-libs and ia32-libs-gtk to all packages
- adds a Provides: ia32-abi
- introduces new ia32-apt-get/ia32-aptitude/ia32-dpkg/ia32-dpkg-deb
  wrapper scripts that preserve the old functionality

Now why should anyone sponsor that?

Simple. The ia32-apt-get/ia32-aptitute will allow users that have
already installed ia32-apt-get to update their ia32-lib* packages to
ones that "Provide: ia32-abi".

Then when Mark later uploads ia32-libs and ia32-libs-gtk he can
"Conflicts: ia32-abi", "Replaces: ia32-abi" to get a smooth
transition. Without this ia32-libs and ia32-libs-gtk would have to
Conflicts/Replaces on over 160 packages which would be a real pain.

So this is a call to all ia32-apt-get haters to sponsor the upload so
Mark can replace it later on.


PS: Thanks to Mark Hymers for being not just talk like many other.

Reply to: