[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: RFS: cracklib2

On Sat, Aug 16, 2008 at 06:31:27PM +0200, Jan Dittberner wrote:
> I am looking for a sponsor for the new version 2.8.12-4
> of my package "cracklib2".
> It builds these binary packages:
> cracklib-runtime - runtime support for password checker library
> cracklib2
> libcrack2  - pro-active password checker library
> libcrack2-dev - pro-active password checker library - development
> python-cracklib - Python bindings for password checker library cracklib2
> The package appears to be lintian clean.
> The package can be found on mentors.debian.net:
> - URL: http://mentors.debian.net/debian/pool/main/c/cracklib2
> - Source repository: deb-src http://mentors.debian.net/debian unstable
>   main contrib non-free
> - dget http://mentors.debian.net/debian/pool/main/c/cracklib2/cracklib2_2.8.12-4.dsc
> I would be glad if someone uploaded this package for me.
> My regular sponsor Martin Pitt is on vacation and told me to ask someone
> else to upload the package.

I didn't get a reply to this RFS yet, so I'll explain the minor
changes between 2.8.12-3 and 2.8.12-4 in more detail:

Lintian has two warning for 2.8.12-3:

1.) patch-system-but-direct-changes-in-diff (due to using autogen.sh in
2.) command-with-path-in-maintainer-script (due to an absolute path to
    /usr/sbin/update-cracklib in postinst)

I fixed both issues 1. by creating a patch instead of calling
autogen.sh in debian/rules and 2. by removing /usr/sbin in the
postinst script.

Here is the changelog entry for the 2.8.12-4 release:

 cracklib2 (2.8.12-4) unstable; urgency=low
   * add debian/patches/05-use-autogen_sh.patch instead of calling
     autogen.sh (fixes Lintian warning
   * debian/control: remove build dependencies to autoconf, automake and
   * remove absolute path to update-cracklib from
     debian/cracklib-runtime.postinst (fixes Lintian warning
   * update regular expression in debian/watch to not match obsolete 3.0pre
  -- Jan Dittberner <jan@dittberner.info>  Fri, 15 Aug 2008 20:52:29 +0200

The last change (regarding the watch file) is necessary because
sourceforge still shows an old upstream file for a cracklib 3.0
prerelease. The 3.0 branch was discarded a while ago and should not be
considered for updating the cracklib2 package.

There are no code or other disruptive changes between 2.8.12-3 and
2.8.12-4 and I hope this eases the decision to upload this package for
a prospective sponsor. So please have a look at the package and upload
it because it will improve the package's quality.

Jan Dittberner

Attachment: signature.asc
Description: Digital signature

Reply to: