[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Are soname bumps required when library upgrades break compatability?



Brandon <winterknight@nerdshack.com> (10/09/2007):
> Might seem like a silly question to most people. But is it required to
> bump the soname of a library when it breaks ABI compatability with an
> older version? I always thought that is was, but I can't find anything
> in debian-policy that says that it is required. In fact, it isn't even
> suggested.

You may want to read libpkg-guide.

Cheers,

-- 
Cyril Brulebois

Attachment: pgpuUUzwhIhgE.pgp
Description: PGP signature


Reply to: