[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: packages newer in Ubuntu than in Debian (reduced false positives)

On Tue, 2007-05-01 at 11:49 +0200, Martin Michlmayr wrote:
> * Bart Martens <bartm@debian.org> [2007-05-01 11:21]:
> > Another approach for identifying packages to be updated in Debian to
> > newer upstream releases is by comparing Debian with Ubuntu.  Here is a
> > list of packages that are newer in Ubuntu than in Debian, grouped by
> > maintainer:
> > http://people.debian.org/~bartm/borg/outdated.html
> The first package in your list shows that you're not handling epochs
> properly.  1.0~rc1-13 vs 2:1.0~rc1-0ubuntu9.  Debian isn't out of date
> here.  You need to ignore epochs.

The handling of epochs is correct, but some packages have different
epochs in Debian and Ubuntu for the same upstream version.

I have updated the list to hide packages with identical upstream version
numbers but with different epochs.  This might hide some real positives
but most likely hides more false positives.

So thanks for the feedback; this is useful.


Bart Martens

Reply to: