[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Lintian error about missing debconf dependency (which is not missing)


On Wed, Dec 21, 2005 at 04:18:13PM -0800, Steve Langasek wrote:
> > The strange thing is, that I have the following line in the control file:
> > Depends: ${misc:Depends}, iptables (>=1.2.11), gawk, debconf (>=1.3.22) | debconf-2.0
> > There is clearly a versioned debconf dependency. The above line is
> > expanded to the following when building the package.
> > Depends: debconf (>= 0.5) | debconf-2.0, iptables (>= 1.2.11), gawk, debconf (>= 1.3.22) | debconf-2.0
> > Does anybody know where the problem is?
> It's pretty likely that the lintian check is buggy in this case;
> nevertheless, your depends: line is *also* buggy.
>   Depends: debconf (>= 0.5) | debconf-2.0, debconf (>= 1.3.22) | debconf-2.0
> Reduces to
>   Depends: debconf (>= 1.3.22) | debconf-2.0
> *but*, this in turn reduces to 
>   Depends: debconf-2.0
> because there are versions of debconf older than 1.3.22 which provide
> debconf-2.0 (the Provides: was introduced in debconf 1.2.30), so they
> satisfy the second branch of the dependency relationship when they
> *shouldn't*.
> If you depend on newer features than those guaranteed by the debconf-2.0
> interface, you will need to depend on the providers of those features
> explicitly, *without* an or on "debconf-2.0".
Thanks. I did'nt realize this fact. So if I get you right the solution
would be to get rid of the debconf-2.0 dependency. If I do so lintian is
fine, but I guess Joey Hess is not:

(and follow-ups)

This post was the reason why I included this dependency in the first

As the debconf-2.0 package's purpose is to allow transition to cdebconf,
is depending on cdebconf explicitely as an alternative to debconf an
option? How compatible are those 'alternatives' currently. 



GPG key:  1024D/3144BE0F Michael Hanke
ICQ: 48230050

Attachment: signature.asc
Description: Digital signature

Reply to: