[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: (slightly more complex) library upgrade

Arjan Oosting wrote:
> Op wo, 21-12-2005 te 13:31 +0100, schreef Michael Biebl:
>>So, in order to achieve the removal of libpowersave7 and assure the
>>functioning of kpowersave during the upgrade, should I add a
>>Conflicts/Replaces: libpowersave7 to libpowersave10 (although this is
>>actually not the case) or should I use a versioned depends on powersaved
>>in kpowersave and move the libpowersave to oldlibs after the upgrade?
>>The Conflicts/Replaces solution would assure that the upgrade of
>>libpowersave is hold back until the new kpowersave is available. But it
>>seems to me that this is more of a hack and doesn't correctly reflect
>>the situation (libpowersave7+10 *can* be installed in parallel).
>>Moving libpowersave7 to oldlibs on the other hand wouldn't automatically
>>remove it. But at least it would make it easier for the user to spot,
>>that it could be safely removed.
>>What would you suggest, what is the cleanest solution?
> Do NOT do the conflicts/replaces routine. Aptitude will remove the
> library from the users system when no package needs it anymore.

But this is only true for aptitude, other frontends like synaptic and
apt itself do not automatically remove unused libraries.

> Deborphan also will tell that the library is not used anymore, so the
> user knows is ca n be removed from there system. Just don't force the
> removal!

I doubt that unexperienced users will use deborphan. But well, I think
there is no perfect solution then.

About keeping kpowersave functional during the upgrade, I probably will
upload an updated kpowersave-0.4.5 version which adds a versioned
Depends on powersaved (<< 0.10). This way the upgrade of
powersaved-0.10.21 is held back until the updated kpowersave is
available in unstable too.

Thanks for your comments,

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: