[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#342381: qterm - FTBFS: error: unknown escape sequence '\='

* LI Daobing [Thu, 08 Dec 2005 07:58:40 +0800]:


> On 12/8/05, Bastian Blank <waldi@debian.org> wrote:
> > Package: qterm
> > Version: 0.4.0pre3-2+b1
> > Severity: serious

> > There was an error while trying to autobuild your package:

> I have prepared a version to fix this problem, but I need a
> sponsor[1], can you help me:

> http://lists.debian.org/debian-mentors/2005/12/msg00031.html[1]

> qterm (0.4.0pre3-3) unstable; urgency=low

>   * libstdc++ allocator transition:
>     - debian/control: build depends on libarts1-dev (>= 1.4.3-2)
>   * new patches/03-unknown_escape_sequence.dpatch:
>     - the newest g++ treat "\=" as an error instead of warning.
>   * bug 333101 in libssl-dev have been closed:
>     - debian/control: build depends on libssl-dev (>= 0.9.8a-4)
>     - delete patches/02-openssl.dpatch
>   * update patches/00list

  FWIW, this failure is caused only by g++_4.0.2-4. If you closely watch
  a build of 0.4.0pre3-2 with g++_4.0.2-5, the same warning about \= is
  emitted, but the build succeeds.

  So, this upload is really not necessary: qterm will get rescheduled to
  build when all buildds have g++_4.0.2-5 installed. But you may as well
  proceed: it really seems it builds fine with -4 and the patch applied.


Adeodato Simó                                     dato at net.com.org.es
Debian Developer                                  adeodato at debian.org
                             Listening to: Pet shop boys - Metamorphosis

Reply to: