[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-Depend on virtual packages

On Mon, Jun 13, 2005 at 12:40:51PM +0200, Goswin von Brederlow wrote:
> Steve Langasek <vorlon@debian.org> writes:
> > On Mon, Jun 13, 2005 at 10:15:30AM +0200, Stefano Zacchiroli wrote:
> >> [ Mail-Followup-To: set to debian-mentors only ]
> >
> >> On Mon, Jun 13, 2005 at 09:57:25AM +0200, Goswin von Brederlow wrote:
> >> > You can't Build-Depend on virtual packages.
> >
> >> Ok, time to settle down this issue.
> >
> >> We do, all ocaml packages build depends on ocaml-3.08.3 a virtual
> >> package provided by ocaml. What's the problem with that? It has worked
> >> properly for two years or so.
> >
> > Then you've been lucky.  I don't think I've ever seen a clear statement that
> > virtual build dependencies *should* work, but they usually *do* work --
> > *except* when there are bugs, which has happened from time to time.  It
> > seems that sbuild particularly likes to object to build-dependencies on
> > virtual packages that were once real packages (e.g., libmysqlclient-dev ->
> > libmysqlclient12-dev).  As a result, it seems to generally be more robust to
> > build-dep on a real package when possible.
> apt-get complains if there is more than one source of the provides
> (even two sources with the same name/version). sbuild then picks the
> first choice apt lists for the provides which is non deterministic and
> strongly discouraged.
> As I said in the past this needs a real metapackage that then depends
> on the actual ocaml package.

We don have this problem, as for both ocaml-<version> and
ocaml-best-pacackages, there is only one real pasckage providing those. The
same happens for things like spamoracle which is provided by spamoracle-byte
on non-native arches.

BTW, stefano, what happened to your presentation in helsinki ?


Sven Luther

Reply to: