[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Fwd: Bug#291946: freemind: Installs with java1.3 but won't works]


new maintainer, I've got the below bug report.
I'm a bit perplex here:
- my current Depends is "Depends: j2re1.4 | java2-runtime, j2re1.4 | java-virtual-machine" - can I put a version dependency on a virtual package? (does then the version come from the version of the real package to which the virtual one is attached?)
- if no, what should I do?
- if yes, should I put it on java2-runtime, on java-virtual-machine or on both?

or to make it more direct, should I change my "Depends" to:
A) Depends: j2re1.4 | java2-runtime (>> 1.4), j2re1.4 | java-virtual-machine (>> 1.4)
B) Depends: j2re1.4 | java2-runtime (>> 1.4), j2re1.4 | java-virtual-machine
B) Depends: j2re1.4 | java2-runtime, j2re1.4 | java-virtual-machine (>> 1.4)
C) something else (precise)
D) nothing to do, forget about it...

Ah, ah, going through the policy, I find (7.4 Virtual packages):
--- BEGIN ---
If a dependency or a conflict has a version number attached then only real packages will be considered to see whether the relationship is satisfied (or the prohibition violated, for a conflict) - it is assumed that a real package which provides the virtual package is not of the "right" version. So, a Provides field may not contain version numbers, and the version number of the concrete package which provides a particular virtual package will not be looked at when considering a dependency on or conflict with the virtual package name.

It is likely that the ability will be added in a future release of dpkg to specify a version number for each virtual package it provides. This feature is not yet present, however, and is expected to be used only infrequently.
--- END ---

Does this mean, answer D above is the right one!?

Thanks in advance,

-------- Original Message --------
Subject: Bug#291946: freemind: Installs with java1.3 but won't works
Resent-Date: Mon, 24 Jan 2005 06:18:03 UTC
Resent-From: Pierre Ancelot <eternityos@free.fr>
Resent-To: debian-bugs-dist@lists.debian.org
Resent-CC: Eric Lavarde <deb@zorglub.s.bawue.de>
Date: Mon, 24 Jan 2005 07:02:15 +0100
From: Pierre Ancelot <eternityos@free.fr>
Reply-To: Pierre Ancelot <eternityos@free.fr>, 291946@bugs.debian.org
To: Debian Bug Tracking System <submit@bugs.debian.org>

Package: freemind
Version: 0.7.1-6
Severity: important

I have j2re1.3 (blackdown)
freemind installed anyways, even though it requires j2re1.4

j2re1.3 certainly provides java2-runtime (not verified) which is required by freemind
this is maybe why it installed.

Get a message when starting freemind that it requires j2re1.4 which i have not... (not on sarge at all)

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Kernel: Linux 2.6.8-486
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages freemind depends on:
ii j2re1.3 [java2-runtime] Blackdown Java(TM) 2 Runtime Envir ii sablevm [java-virtual-machin 1.1.6-6 Free implementation of Java Virtua

-- no debconf information

Gewalt ist die letzte Zuflucht der Inkompetenz.
    Violence is the Last Resort of the Incompetent.
        Gwalt jest ostatnem schronieniem niekompetencji.
            La violence est le dernier refuge de l'incompetence.
    ~ Isaac Asimov

Reply to: