[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Build-Conficts: gcc-3.3, and varargs

On Sat, Jul 31, 2004 at 08:39:52PM -0400, Justin Pryzby wrote:
> I have a package (x11iraf) which conflicts with gcc-3.3.  For the whole
> story see below..

> gcc includes /usr/bin/gcc which is pretty much a necessity, I think.  I
> need xmkmf to work too.  For now I have Build-Depends: gcc-3.2, but what
> can I do to force it to actually compile with that, instead of gcc-3.3?

Invoke make with CC=gcc-3.2.

If you build-conflict with gcc-3.3, I highly doubt that the autobuilders
will do what you want -- you may even leave the autobuilders in a
completely broken state for any packages which follow you.

Steve Langasek
postmodern programmer

Attachment: signature.asc
Description: Digital signature

Reply to: