[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

How to fix package-has-a-duplicate-relation?

Lintian tells me this:

  package-has-a-duplicate-relation xlibs (>> 4.1.0), xlibs (>> 4.2.0)

I guess it comes in because some of the scanned executable depends on 4.2.0 
while some of the other libraries it depends on are linked against 4.1.0?
How should I fix this?

Also, is there some reason why dh_shlibdeps (dpkg-shlibdeps) couldn't merge 
version intervals (i.e. in this case, remove the 4.1.0 entry since a newer 
version is required anyway)?

- Jarno

Reply to: