[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


I'm using dh_perl to calculate the package dependencies for a perl
script in the cupsys-driver-gimpprint package.  I thought this was
working, but it's not getting the dependencies right.

In debian/rules, I use "dh_perl -a" in the binary-arch target.

$ cat debian/cupsys-driver-gimpprint.substvars | grep ^perl

However, this script has:
use strict;
use Getopt::Std;
use Compress::Zlib;
use Fcntl qw(:mode);
use File::Temp qw(:POSIX);
use File::Copy qw(mv);

of which Compress::Zlib is not a core perl module (it's in
/usr/lib/perl5).  dh_perl isn't adding libcompress-zlib-perl to
perl:Depends, even if I add /usr/lib/perl5 to dh_perl's options.

I could just add the dependency manually, but I'd like to get this
working properly.  Am I doing something wrong here, or is dh_perl not
the correct tool for this?


Roger Leigh

                Printing on GNU/Linux?  http://gimp-print.sourceforge.net/
                GPG Public Key: 0x25BFB848 available on public keyservers

Reply to: