[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#144036: penguineyes-gnome: uses debconf in preinst but does not pre-depends it

Package: penguineyes-gnome
Version: 0.10-21
Severity: serious

[Cc:ing to debian-mentors because I don't know how to fix this bug.
Yes, I am the maintainer of penguineyes, and I want to prevent penguineyes
from entering woody.]

penguineyes and penguineyes-gnome uses debconf in their preinst:

case $1 in
        if [ -n "$2" ]; then
            if dpkg --compare-versions "$2" \<= 0.10-15 && \
                dpkg --compare-versions "$2" \>= 0.10-5 ; then
                . /usr/share/debconf/confmodule
                db_unregister penguineyes/theme

This _seems_ to be a fix for #122809 (I adopted penguineyes recently and
don't know what happened to it).  What should I do?  Pre-Depends: debconf
(>= 0.2.17), move db_unregister to postinst or something else?

-- System Information
Debian Release: 2.2
Kernel Version: Linux grain 2.4.18 #1 Fri Mar 15 18:50:57 JST 2002 i686 unknown

Versions of the packages penguineyes-gnome depends on:
hi  debconf        1.0.18         Debian configuration management system
hi  gdk-imlib1     1.9.11-3       Gdk-Imlib is an imaging library for use with
hi  libart2      The Gnome canvas widget
hi  libc6          2.2.4-7        GNU C Library: Shared libraries and Timezone
hi  libgnome32      The Gnome libraries
hi  libgnomesuppor      The Gnome libraries (Support libraries)
hi  libgnomeui32      The Gnome libraries (User Interface)
hi  libgnorba27      Gnome CORBA services
hi  libpanel-apple     Library for Gnome Panel applets
hi  xlibs          4.1.0-9        X Window System client libraries
ii  libaudiofile0  0.2.3-4        The Audiofile Library
ii  libdb3         3.2.9-14       Berkeley v3 Database Libraries [runtime]
ii  libesd0        0.2.23-3       Enlightened Sound Daemon - Shared libraries
ii  libglib1.2     1.2.10-4       The GLib library of C routines
ii  libgtk1.2      1.2.10-10      The GIMP Toolkit set of widgets for X
ii  liborbit0      0.5.15-1       Libraries for ORBit - a CORBA ORB
libesd-alsa0	Not installed or no info

To UNSUBSCRIBE, email to debian-mentors-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: