[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

new X freezes computer

I've got a grave problem with X, I'd like to ask for help on the mailing
list before I submit a bug.

When I try to start X (using either startx or xdm, I didn't try xinit), it
starts loading, and then the computer freezes up utterly.
Ctrl-Alt-Backspace doesn't shutdown X, Alt-Fn doesn't switch over to a
console.  The computer is completely gone.

This all started last week as libc6 was being raised to version 2.2 (I think
the problem started with v 2.1.97, and then remained with v2.2).  At the
same time, the XFree86 v 4.0.1 packages went through revisions 4.0.1-3
through to -5.

I had XFree86 4.0.1 working from Debian revision 1, which came up two or
three weeks ago.  I installed the server, xfree86-xfree, and it was working
fine (This is on a Toshiba 490CDT laptop with an S3 ViRGE video chipset). It
only stopped working last week with the upgrades I just mentioned.

I tried recompiling the kernel, upgrading it from 2.2.17 to 2.2.18-pre21 in
fact.  I tried purging the xfree86 packages (though, true, some config files
remained in /etc/X11 I think).  After reinstalling, X still doesn't work.
I don't know if the problem is XFree86 or libc6 or what.

I tried catching output by piping output to file: "startx 2>&1 >
startx.log", but the file wasn't there after rebooting after the freeze.
Likewise "strace -o startx.log startx" didn't leave a file.

I've run out of ideas.  Does anyone have clues?


PGP public key available at http://dparsons.webjump.com/drewskey.txt
Fingerprint: A110 EAE1 D7D2 8076 5FE0  EC0A B6CE 7041 6412 4E4A

Reply to: