[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A few new-maintainer questions.



On Mon, Nov 30, 1998 at 07:17:51PM -0500, Zephaniah E, Hull wrote:
> 1: What is a good way for handling the version fields to reflect that
> the upstream version is a beta? In this case the upstream version is
> 1.05beta10, leaving me with a bit of a problem (for when 1.05 is
> actually released)..
> Note that I do have a good reason for packaging the beta version and not
> the stable release before it..

I do it in the case of epic4's help 4-0pre2-2.  It's 4pre2 and the package
revision is -2..  That won't QUITE work in your case unless you result to
evil things:

~$ dpkg --compare-versions 1.05-0beta10-1 '<' 1.05-1 && echo yes || echo no
no
~$ dpkg --compare-versions 1.05-0beta10-1 '<' 1.05.0-1 && echo yes || echo no
yes


> 2: Would anyone be willing to look over my package and make sure that it
> does not violate policy? Currently the only lintian warning is a
> ancient-standards-version, which I am not wanting to bump up to current
> until I'm sure its compliant..

Lintian checks against current standards version (or as current as it knows
about)  You can probably up the standards version to whatever lintian was
built with.  =>


Sorry I can't help more.  =<

-- 
Show me the code or get out of my way.

Attachment: pgpcHnOXH2Mpc.pgp
Description: PGP signature


Reply to: