[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Analysis Takes forever and times out on i386


Currently the last-align package in Debian takes forever to execute its testsuite and eventually times out after 150 minutes of inactivity, leading to a failing test.
Specifically, I manually tried running the commands (in the last-align repo):

$ cd examples
$lastdb -cR01 humdb humanMito.fa
$lastal humdb fuguMito.fa > myalns.maf

And the last command here just takes forever to run. The whole script that currently fails in Debian's test suite can be found here[1]

This problem occurred only after updating to last-align version 1167, till 1145, it worked  just fine as can be seen here[2].
The log currently timing out can be found here[3]

[1]: https://salsa.debian.org/med-team/last-align/-/blob/master/debian/tests/run-unit-test
[2]: https://ci.debian.net/data/autopkgtest/testing/i386/l/last-align/8940721/log.gz
[3]: https://ci.debian.net/data/autopkgtest/testing/i386/l/last-align/8995720/log.gz

Please consider fixing this, or let us know if it is no longer compatible to build on i386, or 
even other 32-bit arches.

Kind regards

Reply to: