[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: picard-tools upgrade



On Fri, May 29, 2020 at 12:03:14PM +0200, olivier sallou wrote:
> hi,
> trying to upgrade picard-tools, and as usual, it breaks.....
> 
> I started to update patches etc... and need more patching :-(
> but current issue is that, as usual, it makes use of htsjdk functions not
> available in current debian version.
> 
> picard-tools and htsjdk are always closely linked... so means that we first
> need to upgrade htsjdk, which is used by other tools and it also often
> breaks its ABI so may have some impacts.
> 
> in fact we should almost have a picard-tools-X and htsjdk-Y new package
> with each release....
> 
> anyway, do you think we should go for an htsjdk upgrade with all the
> impacts it may have?

As far as I remember we always have bumped htsjdk together and we'll see
what might be broken afterwards.  Luckily we have quite some autopkgtest
coverage so obvious issues with dependencies should become visible soon.

Thanks a lot for your work on this

     Andreas.

-- 
http://fam-tille.de


Reply to: