[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Wishlist for the sprinters.

On Wed, Feb 01, 2012 at 12:58:22PM +0900, Charles Plessy wrote:
> I have set sharedRepository = all and changed the group of the files to
> “Debian”, in which we both belong.  I hope that this now allows you to push.

I can confirm that push works now.
> I have tried your patch, but with or without I have the following error:
>   You must specify a valid JAVA_HOME or JAVACMD!

This has nothing to do at all with my patch.  I simply changed the PATH
where the *.so libraries are looked up.

> I shamefully do not remember how I overcame this in the past.

I take it as the usual frustrating Java magic.  If I would be in your
shoes, I would post the whole build log and ask some Java gurus.  Our
"local guru" is Olivier, more of these are hanging around at
> This package is stretching my competence far beyond the limit…  I have
> contacted Upstream, who is quite positive to help, but I simply do not
> understand enough Java's JNI libraries to give him useful recommendations…

When I try git-buildpackage I get:

---------------------- start buildlog ---------------------------------

$ git-buildpackage
test -x debian/rules
mkdir -p "."
/usr/share/maven-debian-helper/copy-repo.sh /home/tillea/debian-maintain/alioth/debian-med_git/snappy-java/debian
mh_patchpoms -plibsnappy-java-java --debian-build --keep-pom-version --maven-repo=/home/tillea/debian-maintain/alioth/debian-med_git/snappy-java/debian/maven-repo  --build-no-docs --ignore-rules=debian/maven.ignoreRules --clean-ignore-rules=debian/maven.cleanIgnoreRules
touch debian/stamp-poms-patched
cd . && /usr/lib/jvm/default-java/bin/java -noverify -cp /usr/share/maven2/boot/classworlds.jar:/usr/lib/jvm/default-java/lib/tools.jar -Dproperties.file.manual=/home/tillea/debian-maintain/alioth/debian-med_git/snappy-java/debian/maven.properties -Dclassworlds.conf=/etc/maven2/m2-debian.conf org.codehaus.classworlds.Launcher -s/etc/maven2/settings-debian.xml -Dmaven.repo.local=/home/tillea/debian-maintain/alioth/debian-med_git/snappy-java/debian/maven-repo  clean
NOTE: Maven is executing in offline mode. Any artifacts not already in your local
repository will be inaccessible.

[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Error building POM (may not be this project's POM).

Project ID: org.apache.felix:maven-bundle-plugin

Reason: POM 'org.apache.felix:maven-bundle-plugin' not found in repository: System is offline.


 for project org.apache.felix:maven-bundle-plugin

[INFO] ------------------------------------------------------------------------
[INFO] For more information, run Maven with the -e switch
[INFO] ------------------------------------------------------------------------
[INFO] Total time: < 1 second
[INFO] Finished at: Wed Feb 01 08:13:51 CET 2012
[INFO] Final Memory: 1M/57M
[INFO] ------------------------------------------------------------------------
make: [cleanbuilddir] Fehler 1 (ignoriert)
rm -f -r /home/tillea/debian-maintain/alioth/debian-med_git/snappy-java/debian/maven-repo debian/stamp-maven-build
rm -f debian/*.substvars
/usr/bin/make -f debian/rules unpatch-poms
make[1]: Entering directory `/home/tillea/debian-maintain/alioth/debian-med_git/snappy-java'
mh_unpatchpoms -plibsnappy-java-java
rm -f -f debian/stamp-poms-patched
make[1]: Leaving directory `/home/tillea/debian-maintain/alioth/debian-med_git/snappy-java'
mh_unpatchpoms -plibsnappy-java-java
rm -f -f debian/stamp-poms-patched
gbp:error: You have uncommitted changes in your source tree:
gbp:error: # On branch master
# Untracked files:
#   (use "git add <file>..." to include in what will be committed)
#       debian/patches/use_debian_packaged_libsnappy.patch
nothing added to commit but untracked files present (use "git add" to track)

gbp:error: Use --git-ignore-new to ignore.

$ git diff

---------------------- end buildlog ---------------------------------

So it seems I have in general no luck using ${VCS}-buildpackage and I
again switch back to a more robust way.

$ pristine-tar checkout snappy-java_1.0.4.1.orig.tar.gz

untar this and copy debian/ dir into it.  This worked perfectly. 

Because you wrote that this package somehow is beyond your limit I took
the freedom to follow my advise to strip the useless binaries in a
get-orig-source target.  This seems to be reasonable after I noticed
that you also striped parts of the original source.  I regarded this
in a debian/get-orig-source script which is used by debian/watch and
added a get-orig-source target to debian/rules.  I really prefer to
do changes like these in a generic way recommended in best practices
rather than relying on specific git features.

I have uploaded source and binary package to


Please also watch the build log - no problem with JAVA environment
variables.  It might make sense to test the *.deb package if it really
fullfills the intended purpose you wanted to use it for.

Kind regards



Reply to: