[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#506992: vtk: diff for NMU version 5.6.1-6.1

On Wed, Aug 24, 2011 at 5:48 AM, Steve M. Robbins <steve@sumost.ca> wrote:
> On Tue, Aug 23, 2011 at 08:18:04AM +0200, Mathieu Malaterre wrote:
>> VTK ships a convenient FTGL 1.32 version (April 23 2002),
> I guess the question really is twofold:
>  1. Are there any patches to 1.32 in the VTK tree?

no. I do not believe upstream has worked on using a new ftgl.

>> while debian
>> archive contains 2.1.3 since 2008-05-03
>> The API changed a bit.
>  2. Is upgrading the lib going to break any hidden assumptions made by VTK?

likely/maybe ?

> Certainly it's good to remove duplicate library copies, but we should
> be careful not to introduce regressions.  If this effort is successful,
> please send it upstream; c.f. http://www.vtk.org/Bug/view.php?id=3824

As said previously, I believe #506992 is starting to block other
packages, so it would be nice to make some progress on this. My
suggestion was to remove convenient sqlite copy, and use a lintian
override for ftgl and re-upload.

Denis, did you made any progress on ftgl patch ? Do you have any
comment on Steve's points ?

Thanks all,

Reply to: