[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [SECURITY] [DLA 1488-1 (invalid)] spice security update



Dear all,

On  Fr 31 Aug 2018 23:30:53 CEST, Mike Gabriel wrote:

Package        : spice
Version        : 0.12.5-1+deb8u6
CVE ID         : CVE-2018-10873
Debian Bug     : #906315


A vulnerability was discovered in SPICE before version 0.14.1 where the
generated code used for demarshalling messages lacked sufficient bounds
checks. A malicious client or server, after authentication, could send
specially crafted messages to its peer which would result in a crash or,
potentially, other impacts.

The issue has been fixed by upstream by bailing out with an error if the
pointer to the start of some message data is strictly greater than the
pointer to the end of the  message data.

For Debian 8 "Jessie", this problem has been fixed in version
0.12.5-1+deb8u6.

We recommend that you upgrade your spice packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

please note that this DLA email has been sent under the wrong DLA number (was: DLA-1488-1, should have been DLA-1486-1).

A new email announcement for the recent upload of spice to Debian LTS has been sent as DLA-1486-1 to this mailing list, please reference that in case of occuring regressions or other issues you find in the uploaded package.

Sorry for the inconvenience,
Mike
--

mike gabriel aka sunweaver (Debian Developer)
mobile: +49 (1520) 1976 148
landline: +49 (4354) 8390 139

GnuPG Fingerprint: 9BFB AEE8 6C0A A5FF BF22  0782 9AF4 6B30 2577 1B31
mail: sunweaver@debian.org, http://sunweavers.net

Attachment: pgpxwfzmpnMAI.pgp
Description: Digitale PGP-Signatur


Reply to: