[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[SECURITY] [DLA 1414-1] mercurial security update

Package        : mercurial
Version        : 3.1.2-2+deb8u5
CVE ID         : CVE-2017-9462 CVE-2017-17458 CVE-2018-1000132
Debian Bug     : 861243 892964 901050

Some security vulnerabilities were found in Mercurial which allow
authenticated users to trigger arbitrary code execution and
unauthorized data access in certain server configuration. Malformed
patches and repositories can also lead to crashes and arbitrary code
execution on clients.


    In Mercurial before 4.1.3, "hg serve --stdio" allows remote
    authenticated users to launch the Python debugger, and
    consequently execute arbitrary code, by using --debugger as a
    repository name.


    In Mercurial before 4.4.1, it is possible that a specially
    malformed repository can cause Git subrepositories to run
    arbitrary code in the form of a .git/hooks/post-update script
    checked into the repository. Typical use of Mercurial prevents
    construction of such repositories, but they can be created


    Mercurial version 4.5 and earlier contains a Incorrect Access
    Control (CWE-285) vulnerability in Protocol server that can result
    in Unauthorized data access. This attack appear to be exploitable
    via network connectivity. This vulnerability appears to have been
    fixed in 4.5.1.


    mpatch: be more careful about parsing binary patch data


    mpatch: protect against underflow in mpatch_apply


    mpatch: ensure fragment start isn't past the end of orig

For Debian 8 "Jessie", these problems have been fixed in version

We recommend that you upgrade your mercurial packages.

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Attachment: signature.asc
Description: PGP signature

Reply to: