[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Sarge and LSB V2.0 lsb-runtime test results

On Wed, 2005-06-15 at 14:59 -0400, Dave Neil wrote:
> Here's the results for the LSB V2 lsb- runtime test on the just released 
> Debian Sarge. Please note that the test did not successfully complete 
> without our intervention. The test hung during the following test: 
> tset/PTHR.os/procprim/sigwait/T.sigwait 
> This happened twice and we interrupted that test after 10+ hours, and 
> then the lsb-runtime completed the rest of its tests.

That's happened to us on several occasions as well.  I'll see if I can
find my notes about the problem.  As I recall, it was fairly random.

> http://support.xandros.com/lsb/report.200506101606

Would it be possible to post the journal?  That file should be in a
directory like "/home/tet/test_sets/results/0001e/journal".

That, or a tjreport would work.  There's a tool called "tjreport" which
produces a greatly abridged report listing only the problems and some
summary data.  There should be a "tjreport" tool in $PATH; run that tool
on your journal to get the report.

> Note we will be posting the results of the rest of the LSB V2 tests 
> shortly, but have spent much time running the lsb-runtime tests in order 
> to work around the issue noted above.

It's my recollection that the runtime test is the most serious.  The
other tests should not pose any serious problems.

Note that this is no longer true with the LSB 3.0 tests.  I'll be
posting my results from that soon.

Reply to: