[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: PAM beta test results for Debian unstable

> run_tests issues
> ================
> After running run_tests and answering some questions I got 
> this error on ia64,
> The LSB loader /lib/ld-lsb.so.1 does not exist. The
> test suites will not run without it. If you are running this
> on a non LSB compliant system and still wish to execute the
> test suites then creating a symlink for /lib/ld-lsb.so.1 to
> /lib/ld-linux.so.2 before re-running this program is most
> likely the correct thing to do.
> So it's looking for the ia32 linker. Changing run_tests to,
> LDSO=/lib/ld-lsb-ia64.so.1
> allows it to proceed. It looks like lsb-runtime-test's 
> version of run_tests  gets this right.

Damn.  I've rebuilt the pam tests for ia64 and uploaded.
The information here is not actually part of the test suite, 
but is generated by rpm at build time (that is, run_tests is 
a file generated at packaging time). The architecture check 
in the rpm specfile was too precise, so it worked fine for 
Chris on a Debian system, but ended up wrong when I built on 
a Red Hat system.  I redid the runtime test when I ran into
this, but didn't realize I also needed to do it for pam.

This won't change anything about how the test works otherwise,
so no real point in rerunning.

Reply to: