[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Live Build on Debian

Hey again, I have managed to at least figure out the cause of the issue.

The package user-setup, which is recommended for live-config, is the culprit here.

If you run lb config with --apt-recommends true, this package will automatically be installed, since you need live-config in your package list for the build.

I tested by using --apt-recommends false and building with and without specifically installing user-setup.

If the user-setup package is installed, and you have files bigger than 1-2GB in your includes.chroot folder, there will be a start job regarding  late user space at boot, running for at least 30 sec to 2 min.

If the package is not installed, booting works flawlessly without any start jobs, however you cannot login anymore, because no user/password has been assigned, due to the lack of user-setup.

I have unsuccessfully tried to fix this by both simply using --bootappend-live to assign a username and a livehook that creates one with adduser.

The default user / live   name/password combo does not work, though.

Not sure if this is a bug, but I will report back after I know more.

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Wednesday, February 17, 2021 2:33 PM, mike.goldberg1 <mike.goldberg1@protonmail.com> wrote:

Hey eznix, thank you for taking the time to reply.

Excatly, when I do not include these large file(s), the start job does not appear and it boots normally.
Yes, I have experimented with boot appends like nouveau.modeset=0 or blacklisting it outright, but the described behavior persists.

I have done some extensive testing, and these are my findings so far:

1.)Running lb-config with --apt-recommends false seems to solve this issue, so it must be some recommended package at the root of it all. The downside of this "fix" is that I can't login anymore after the iso boots, because the default password/username aren't set up, correctly.

2.)Another way to get around this start job is to use
lb config --distribution sid  --parent-distribution buster
With these options the start job still appears when including large files, however it's gone within a matter of 1-2 seconds and you can boot/login normally.

In summary, I have figured out ways to kind of circumvent the issue, but as always, I would like to truly understand what exactly the problem is in order to find a perfect fix for it. Otherwise it will just keep me up at night lol.
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Wednesday, February 17, 2021 6:33 AM, ezsit55 <ezsit55@gmail.com> wrote:

Sorry, I do not have an answer for you. Does this start job appear if you do not include those massive files in the iso? Most searching points to a video driver or no-modesetting grub option.

On 2/15/21 3:12 PM, mike.goldberg1 wrote:
Hello everybody!

Building on Debian Buster.
When I add larger files (1-2GB) via includes.chroot to /etc/skel, the build still completes successfully and the iso works as well, but at boot it says "A start job is running for live-config (late userspace) which takes about 2min until it boots.

Anybody know why this is happening and how to avoid it?

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Friday, January 29, 2021 12:22 AM, mike.goldberg1 <mike.goldberg1@protonmail.com> wrote:

Hi everyone!

Live build works great on Debian 10 but I cannot figure out something.

My Goal >
1)Change the user password of the live user
2)Have all applications request the password like on a regular install

Solution >
1)Remove /etc/sudoers.d/live which live-build creates by default and contains the line that is added to the /etc/sudoers file and causes all apps to run without password prompt. Namely  "user  ALL=(ALL) NOPASSWD: ALL" 

2)Write a hook which sets a new user password at boot, since the user is created at this time by live-config.

The live build manual recommends to use the passwd example hook located in /usr/share/doc/live-config/examples/hooks and add it to config/includes.chroot/lib/live/config/

This did not work for me at all, unfortunately. Also, I wasn't quite sure what "prefix" needed to be applied, since this actually runs at boot time. I called mine "2000-passwd.hook.chroot".

I also tried by creating my own hook to change the passwd at boot time, by placing it in the same directory, but this also failed.
This was my command "echo user:pass | /user/sbin/chpasswd"

Any help would be appreciated!

Reply to: