[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: live-build generates problems due exim4 as mail-transport-agent why?



El mar., 21 de may. de 2019 a la(s) 10:20, Andreas Heinlein (aheinlein@gmx.com) escribió:
this answer may be a bit late, but I hope it will still be useful.
for this kind of problems NEVER ARE LATE! it's wrong think that in future nobody will tray made some in older way!
 
You shouldn't make any package customizations in the debootstrap stage
as you did. This is only useful for packages which are absolutely
required for installing further packages later in the chroot stage.
apt-transport-https and ca-certificates belong to this category.

Instead, try putting

courier-mta
exim4-config-
exim4-daemon-light-

thnks for response!

NOW A QUESTION: how then this only works for chroot, but so then for debootstrp  if i wants something from backport or customized how can be made it?


 

in e.g. config/package-lists/mylist.list.chroot

Note the dash at the end of the exim4 packages, this should instruct
apt/aptitude to remove these packages instead of install them.

Bye,

Andreas

Am 18.05.19 um 20:29 schrieb PICCORO McKAY Lenz:
> Live build seems have a problem, i do not want a exim4 packages in
> deboostrap, so
>
> i especified at the config that includes openssl and courier-mta event exim4
>
> but i have this result:
>
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  courier-mta : Conflicts: mail-transport-agent
>  exim4-config : Conflicts: courier-mta but 0.73.1-1.6 is to be installed
>  exim4-daemon-light : Conflicts: mail-transport-agent
>  ifupdown : Breaks: systemd (< 228-3~) but 215-17+deb8u13 is to be installed
> E: Unable to correct problems, you have held broken packages.
> P: Begin unmounting filesystems...
> P: Saving caches...
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
>
>
> mi config in auto directory are:
>
> lb config noauto \
>       --clean \
>       --mode debian \
>       --linux-flavours "486 686-pae" \
>       --linux-packages "linux-image linux-headers" \
>       --system live \
>       --debian-installer live \
>       --debian-installer-gui true \
>       --debootstrap-options
> "--include=apt-transport-https,ca-certificates,openssl,courier-mta" \
>       --apt-recommends false --apt-secure false --apt-source-archives false \
>       --apt-options "--yes --force-yes -oAcquire::Check-Valid-Until=false
> --allow-unauthenticated" \
>       --checksums none \
>       --binary-images iso-hybrid \
>       --memtest memtest86+ \
>       --win32-loader false \
>       --verbose \
>    {@}
>
>
>


Reply to: