[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Persistence not working on image files


persistence is not working when persistent storage is image file. When it is a disk partition, it's ok.

I am trying to make live system with persistence file.

# dd if=/dev/null of=rw.ext4 bs=1 count=0 seek=20M
# mkfs.ext4 -F -L persistence rw.ext4
# mount rw.ext4 /mnt
# echo /etc > /mnt/persistence.conf
# umount /mnt

# mount /dev/sda1 /mnt
# mv rw.ext4 /mnt/live

# ls /mnt/live
filesystem.squashfs initrd.img vmlinuz rw.ext4

# cat /mnt/grub/grub.conf
set timeout=4
set default=0
menuentry "Live" {
	set root=(hd0,1)
linux /live/vmlinuz boot=live nocomponents quiet persistence persistence-path=/live persistence-label=rw
	initrd /live/initrd.img

After boot the system mounts rw.ext4 but it does not proceed well to make persistence. If I use a partition as a persistence media, the similar simple way as above, it works ok.

I tried stable (wheezy) live system downloaded from the web as well as a system built myself with latest live-* packages. File persistence didn't work in either case, partition persistence tried only once with latest live-* packages.

Vladimir Smelhaus

Reply to: