[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: funny behavior of cgi online builder with sid



Greetings,


On Fri, Nov 15, 2013 at 9:47 PM, carolus <worwor@bellsouth.net> wrote:
On 11/15/2013 9:39 PM, Richard Nelson wrote:
Greetings,


On Fri, Nov 15, 2013 at 9:00 PM, Richard Nelson <unixabg@gmail.com
<mailto:unixabg@gmail.com>> wrote:

    Greetings,


    On Fri, Nov 15, 2013 at 6:53 PM, carolus <worwor@bellsouth.net
    <mailto:worwor@bellsouth.net>> wrote:

        Build 20131115.204427.380792858

        The error messages are clear:

        E: Unable to locate package virtualbox-guest-dkms
        E: Unable to locate package virtualbox-guest-utils
        E: Unable to locate package virtualbox-guest-x11

        However, those packages were not requested:

        # CGI Packages List
        _LB_CGIPACKAGES=""

        I did request them once, but deleted them after seeing the error
        messages. Twice I resubmitted, and both times the builder
        somehow remembered my initial request and ignored the correction.


    I looked at your build request and looks like you wanted
    xfce-desktop. The packages which are causing issue are requested
    from the following config/package-lists:

    http://live.debian.net/gitweb/?p=live-images.git;a=blob;f=images/xfce-desktop/config/package-lists/dkms.list.chroot_live;h=1ef267bebd8531ff4bd6c3f58e49f2b2940af412;hb=59da385e8ae473ac64f288093a6889a0564b573d

    I will try to run a couple of builds and see if I can figure out why
    the failure.


I think the issue is that the main archive area only has
virtualbox_4.1.18 items and sid expects virtualbox_4.2.16 according to
http://packages.qa.debian.org/v/virtualbox.html . The virtualbox_4.2.16
packages are in the contrib archive area, not main. Since the cgi online
builder uses LB_ARCHIVE_AREAS="main" sid builds will fail as you describe.

Does this issue affect only the xfce desktop, or all sid desktops?



I only did a quick check but I think all the gui desktops on cgi builder with sid builds would have this issue.

Thanks.

 

--
To UNSUBSCRIBE, email to debian-live-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: l66pse$v0h$1@ger.gmane.org" target="_blank">http://lists.debian.org/l66pse$v0h$1@ger.gmane.org



Reply to: