[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#578136: marked as done (support uuid by default)

Your message dated Wed, 19 Jun 2013 07:39:28 +0200
with message-id <51C14410.8050302@progress-technologies.net>
and subject line Re: support uuid by default
has caused the Debian Bug report #578136,
regarding support uuid by default
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

578136: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=578136
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: live-initramfs

Downloaded image from here:

All md5sums check out ok at all stages.

Then undertook following steps:
1. Mounted image and copied all contents (including .disk directory)
to third partition of flash drive.
2. Changed name of isolinux directory and isolinux.cfg to syslinux;
edited all configuration files in isolinux directory to say "syslinux"
in path; did not change name of isolinux.bin.
3. Installed syslinux from Puppy Linux on to boot record of this partition.
4. Included stanza in Grub on MBR of flash drive to boot from
partition using chainloader.

This procedure has worked fine with seven other Live CD images so far,
including three other Debian Live images (LXDE and GNOME versions for
Lenny from Debian Live site; Debian Eee 1.0b3 image, based on
Squeeze).  All have booted normally and allowed me to run persistent

Upon boot, main menu is presented.  Choosing option for "Live" or
"686" (and possibly all other options as well, have not tried)
initiates boot sequence.  Just after the line "squashfs 4.0" appears,
boot process halts with this message:

Can not mount /dev/loop0 (/live/image/live/filesystem.squashfs) on

The file live.log that is created contains this:

Mounting "/live/image/live/filesystem.squashfs" on "filesystem.squashfs"
via "/dev/loop0" ... mount: mounting /dev/loop0 on //filesystem.squashfs
failed : Invalid argument

I rechecked all checksums, they check out.  In case it was a version
mismatch I ran "file filesystem.squashfs" from Puppy Linux and got

/mnt/cdrom/live/filesystem.squashfs: Squashfs filesystem, little
endian, version 4.0, -1880381185 bytes, 149287 inodes, blocksize: 66
bytes, created: Thu Nov 10 06:08:16 1938

So it appears to be a 4.0 squashfs file, which should mount (and
incidentally does mount from Puppy).

Bug 540000 appears to describe a similar event but this was closed
without resolution.  There is also a similar discussion at
but this too did not seem to have been resolved.  Both earlier reports
are much older.

--- End Message ---
--- Begin Message ---
Generically, we should not enable uuid by default (which we don't,

If we would enable it by default, it would fix this edge case issue, but
it would make live images way more complicated in all other cases.
Therefore, it is better to only require user invervention when it is
actually needed, and I'm closing this bug.

Address:        Daniel Baumann, Donnerbuehlweg 3, CH-3012 Bern
Email:          daniel.baumann@progress-technologies.net
Internet:       http://people.progress-technologies.net/~daniel.baumann/

--- End Message ---

Reply to: