[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem installing cups-pdf on live-build

On Fri, Aug 10, 2012 at 12:43:58PM +0300, Cavit VURAL wrote:
> Hi ,
> In wheezy the version of cups-pdf is 2.6.1-6 and still it asks for root
> password
> Cavit VURAL
> 10-08-2012 12:40 tarihinde, Rui Bernardo yazdı:
> > On Fri, Aug 10, 2012 at 10:15:34AM +0200, Robert Spiteri wrote:
> >> Am using live-build including cups-pdf and am being asked for the root
> >> password? This breaks automation of build.
> >>
> >> Is there something to be setup in the lb config which I am not aware of please?
> >>
> >> System: Debian Squeeze (stable), kernel version 2.6.32-5-686
> >>
> >> --
> >> Robert
> >>
> > Hi,
> >
> > I think that was not supposed to happen, like it doesn't happen with 
> > mysql or others.
> >
> > Searching the BTS I've found a bug report similar to the problem you 
> > discribed: http://bugs.debian.org/539156 (and 614713).
> >
> > The (supposed to be) fixed package version is 2.5.1-3. What is the 
> > package version that is installed in your build?
> >
> > Hope it helps.
> >
> >

> begin:vcard
> fn:Cavit VURAL
> n:VURAL;Cavit
> org:Adak Teknoloji
> adr;quoted-printable;quoted-printable;quoted-printable;quoted-printable;dom:No :42/39 Camialt=C4=B1;;=C4=B0.A.O.S.B Merkez =C3=87ar=C5=9F=C4=B1 ;=C4=B0zmir;=C3=87i=C4=9Fli;35610
> email;internet:cavit.vural@adak.com.tr
> url:http://www.adak.com.tr
> version:2.1
> end:vcard

Did that happen in "sudo lb build" or you just ran "sudo apt-get install 
cups-pdf" in your computer? I ask that because when I said that this was 
not supposed to happen I meant during the "sudo lb build" execution.

If you install mysql in your system as usual ("sudo apt-get install ..."), you'll be asked for debconf questions, but if you install with

	export DEBCONF_FRONTEND=noninteractive && sudo -E apt-get install cups-pdf

then the debconf defaults should allow the package installation without 
answering any question. I've just tried the line above, in sid:

miguel@quartor:~/$ export DEBCONF_FRONTEND=noninteractive && sudo -E apt-get install cups-pdf
Reading package lists... Done
Building dependency tree        
Reading state information... Done
The following extra packages will be installed:
  cups cups-filters cups-ppdc ghostscript libcupscgi1 libcupsfilters1
  libcupsmime1 libcupsppdc1 libgs9 libgs9-common libijs-0.35 libjbig2dec0
  libpaper-utils libpaper1 libslp1 poppler-data poppler-utils
Suggested packages:
  foomatic-db-compressed-ppds foomatic-db printer-driver-hpcups hplip
  system-config-printer-gnome system-config-printer-kde system-config-printer
  ghostscript-x hpijs slpd openslp-doc fonts-japanese-mincho
  fonts-ipafont-mincho fonts-japanese-gothic fonts-ipafont-gothic
  fonts-arphic-ukai fonts-arphic-uming fonts-unfonts-core
Recommended packages:
  avahi-daemon colord foomatic-filters printer-driver-gutenprint
The following NEW packages will be installed:
  cups cups-filters cups-pdf cups-ppdc ghostscript libcupscgi1 libcupsfilters1
  libcupsmime1 libcupsppdc1 libgs9 libgs9-common libijs-0.35 libjbig2dec0
  libpaper-utils libpaper1 libslp1 poppler-data poppler-utils
0 upgraded, 18 newly installed, 0 to remove and 15 not upgraded.
Need to get 8727 kB of archives.
After this operation, 32,7 MB of additional disk space will be used.
Do you want to continue [Y/n]? 
Get:1 http://ftp2.fr.debian.org/debian/ sid/main libcupscgi1 i386 1.5.3-2 [113 kB]
Get:2 http://ftp2.fr.debian.org/debian/ sid/main libcupsmime1 i386 1.5.3-2 [95,9 kB]
Get:3 http://ftp2.fr.debian.org/debian/ sid/main libcupsppdc1 i386 1.5.3-2 [137 kB]
Get:4 http://ftp2.fr.debian.org/debian/ sid/main libpaper1 i386 1.1.24+nmu2 [21,9 kB]
Get:5 http://ftp2.fr.debian.org/debian/ sid/main libslp1 i386 1.2.1-9 [50,9 kB]
Get:6 http://ftp2.fr.debian.org/debian/ sid/main poppler-utils i386 0.18.4-3 [157 kB]
Get:7 http://ftp2.fr.debian.org/debian/ sid/main libijs-0.35 i386 0.35-8 [20,7 kB]
Get:8 http://ftp2.fr.debian.org/debian/ sid/main libjbig2dec0 i386 0.11+20120125-1 [51,6 kB]
Get:9 http://ftp2.fr.debian.org/debian/ sid/main poppler-data all 0.4.5-8 [1490 kB]
Get:10 http://ftp2.fr.debian.org/debian/ sid/main libgs9-common all 9.05~dfsg-6 [2189 kB]
Get:11 http://ftp2.fr.debian.org/debian/ sid/main libgs9 i386 9.05~dfsg-6 [2342 kB]
Get:12 http://ftp2.fr.debian.org/debian/ sid/main ghostscript i386 9.05~dfsg-6 [82,5 kB]
Get:13 http://ftp2.fr.debian.org/debian/ sid/main cups-ppdc i386 1.5.3-2 [112 kB]
Get:14 http://ftp2.fr.debian.org/debian/ sid/main libcupsfilters1 i386 1.0.18-2+b1 [66,3 kB]
Get:15 http://ftp2.fr.debian.org/debian/ sid/main cups-filters i386 1.0.18-2+b1 [381 kB]
Get:16 http://ftp2.fr.debian.org/debian/ sid/main cups i386 1.5.3-2 [1349 kB]
Get:17 http://ftp2.fr.debian.org/debian/ sid/main libpaper-utils i386 1.1.24+nmu2 [18,1 kB]
Get:18 http://ftp2.fr.debian.org/debian/ sid/main cups-pdf i386 2.6.1-6 [48,7 kB]
Fetched 8727 kB in 4s (1941 kB/s)  
Preconfiguring packages ...
Selecting previously unselected package libcupscgi1:i386.
(Reading database ... 158313 files and directories currently installed.)
Unpacking libcupscgi1:i386 (from .../libcupscgi1_1.5.3-2_i386.deb) ...
Selecting previously unselected package libcupsmime1:i386.
Unpacking libcupsmime1:i386 (from .../libcupsmime1_1.5.3-2_i386.deb) ...
Selecting previously unselected package libcupsppdc1:i386.
Unpacking libcupsppdc1:i386 (from .../libcupsppdc1_1.5.3-2_i386.deb) ...
Selecting previously unselected package libpaper1:i386.
Unpacking libpaper1:i386 (from .../libpaper1_1.1.24+nmu2_i386.deb) ...
Selecting previously unselected package libslp1.
Unpacking libslp1 (from .../libslp1_1.2.1-9_i386.deb) ...
Selecting previously unselected package poppler-utils.
Unpacking poppler-utils (from .../poppler-utils_0.18.4-3_i386.deb) ...
Selecting previously unselected package libijs-0.35.
Unpacking libijs-0.35 (from .../libijs-0.35_0.35-8_i386.deb) ...
Selecting previously unselected package libjbig2dec0.
Unpacking libjbig2dec0 (from .../libjbig2dec0_0.11+20120125-1_i386.deb) ...
Selecting previously unselected package poppler-data.
Unpacking poppler-data (from .../poppler-data_0.4.5-8_all.deb) ...
Selecting previously unselected package libgs9-common.
Unpacking libgs9-common (from .../libgs9-common_9.05~dfsg-6_all.deb) ...
Selecting previously unselected package libgs9.
Unpacking libgs9 (from .../libgs9_9.05~dfsg-6_i386.deb) ...
Selecting previously unselected package ghostscript.
Unpacking ghostscript (from .../ghostscript_9.05~dfsg-6_i386.deb) ...
Selecting previously unselected package cups-ppdc.
Unpacking cups-ppdc (from .../cups-ppdc_1.5.3-2_i386.deb) ...
Selecting previously unselected package libcupsfilters1:i386.
Unpacking libcupsfilters1:i386 (from .../libcupsfilters1_1.0.18-2+b1_i386.deb) ...
Selecting previously unselected package cups-filters.
Unpacking cups-filters (from .../cups-filters_1.0.18-2+b1_i386.deb) ...
Selecting previously unselected package cups.
Unpacking cups (from .../archives/cups_1.5.3-2_i386.deb) ...
Selecting previously unselected package libpaper-utils.
Unpacking libpaper-utils (from .../libpaper-utils_1.1.24+nmu2_i386.deb) ...
Selecting previously unselected package cups-pdf.
Unpacking cups-pdf (from .../cups-pdf_2.6.1-6_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for fontconfig ...
Processing triggers for doc-base ...
Processing 1 added doc-base file...
Registering documents with dwww...
Setting up libcupscgi1:i386 (1.5.3-2) ...
Setting up libcupsmime1:i386 (1.5.3-2) ...
Setting up libcupsppdc1:i386 (1.5.3-2) ...
Setting up libpaper1:i386 (1.1.24+nmu2) ...

Creating config file /etc/papersize with new version
Setting up libslp1 (1.2.1-9) ...
Setting up poppler-utils (0.18.4-3) ...
Setting up libijs-0.35 (0.35-8) ...
Setting up libjbig2dec0 (0.11+20120125-1) ...
Setting up poppler-data (0.4.5-8) ...
Setting up libgs9-common (9.05~dfsg-6) ...
Setting up libgs9 (9.05~dfsg-6) ...
Setting up ghostscript (9.05~dfsg-6) ...
Setting up cups-ppdc (1.5.3-2) ...
Setting up libcupsfilters1:i386 (1.0.18-2+b1) ...
Setting up cups-filters (1.0.18-2+b1) ...
Setting up cups (1.5.3-2) ...
Error: Module usblp is not currently loaded
[ ok ] Starting Common Unix Printing System: cupsd.
Updating PPD files for cups ...
Updating PPD files for cups-filters ...
Updating PPD files for cups-pdf ...
Setting up libpaper-utils (1.1.24+nmu2) ...
Setting up cups-pdf (2.6.1-6) ...
[ ok ] Reloading Common Unix Printing System: cupsd.

No root password was asked here.

Also I've just tried building a squeeze build and could not reproduce 
Robert's problem:

miguel@quartor:~/temp/$ mkdir teste
miguel@quartor:~/temp/$ cd teste
miguel@quartor:~/temp/teste$ lb config -d squeeze
miguel@quartor:~/temp/teste$ echo "cups-pdf" > config/package-lists/cups-pdf.chroot.list
miguel@quartor:~/temp/teste$ sudo lb build
miguel@quartor:~/temp/teste$ cat binary/live/filesystem.packages|grep cups-pdf
cups-pdf	2.5.0-16

And I was not asked for any password during the non interactive 
installation process.

>From reading the bugs reports I think the problem can be in the 
configuration, if one is supplied. I didn't and all went well, even with 
an older package that was installed (2.5.0-16).

All this is not a live-build problem, it's a package install problem or 
with package configuration. See http://bugs.debian.org/cgi-bin/539156#5 
and Debian policy "3.9.1 Prompting in maintainer scripts".

BTW, I wonder where 2.5.1-3 is. It's not in any squeeze repository, not 
even in security. I suppose it never hit squeeze, just unstable (and 
wheezy/testing). And I don't see cups-pdf in debian-backports: 

So the last resort solution for me to Robert's problem, is too backport 
cups-pdf from wheezy to squeeze. If that's not possible, I'd try to 
backport 2.5.1-3 source to squeeze, which _should_ be possible.


Reply to: