[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: live-boot + FAI fails


I digged a bit more into this issue.  Checking the history of the live-boot 
package, I found that the last version that worked for me was 3.0~a25-1.

I fetched the packages from snapshots.debian.org and installed them in the 
chroot and prepared the fai-cd as usual [1].  This CD does not fail as described 
in the privious mail, but boots as expected.

So something must have changed in live-boot* that spoils at least my use case.

Best regards,


[1] (In the chroot:)

root@wheezy:~# ls
live-boot-initramfs-tools_3.0~a25-1_all.deb  live-boot_3.0~a25-1_all.deb
root@wheezy:~# dpkg -i live-boot*
dpkg: warning: downgrading live-boot-initramfs-tools from 3.0~a35-1 to 3.0~a25-1.
(Reading database ... 17595 files and directories currently installed.)
Preparing to replace live-boot-initramfs-tools 3.0~a35-1 (using live-boot-initramfs-tools_3.0~a25-1_all.deb) ...
Unpacking replacement live-boot-initramfs-tools ...
dpkg: warning: downgrading live-boot from 3.0~a35-1 to 3.0~a25-1.
Preparing to replace live-boot 3.0~a35-1 (using live-boot_3.0~a25-1_all.deb) ...
Unpacking replacement live-boot ...
Setting up live-boot-initramfs-tools (3.0~a25-1) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-3-amd64
df: Warning: cannot read table of mounted file systems: No such file or directory
warning: failed to read mtab
live-boot: core filesystems devices utils udev wget blockdev.
W: mkconf: MD subsystem is not loaded, thus I cannot scan for arrays.
W: mdadm: failed to auto-generate the mdadm.conf file.
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no configuration file available.
Setting up live-boot (3.0~a25-1) ...
update-rc.d: warning: live-boot start runlevel arguments (none) do not match LSB Default-Start values (S)
insserv: warning: script 'rcS.distrib' missing LSB tags and overrides
root@wheezy:~# exit
root@wheezy:~# fai-cd -fm /srv/debmirror/ fai-cd.iso

--> CD boots fine

Reply to: