[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: live-boot: mountroot not found


On Wed, Jun 20, 2012 at 8:20 AM, Baurzhan Muftakhidinov
<baurthefirst@gmail.com> wrote:
> Hello,
> I built latest sid-based minimal binary.hybrid.iso image, but failed
> to boot it with fromiso option.
> I did apply the
> (http://live.debian.net/gitweb?p=live-boot.git;a=commit;h=c6daa277dd235ea62fa6988f4b30bae666916fc7)
> latest patch, so the issue is not there.
> I believe, that latest re-location of live-boot scripts caused this
> issue, What I can tell at the moment,
> after playing with the live scripts and re-comressing the initrd image, is this:
> The boot process is being interrupted with the message:
> /init:218 mountroot is not found.  (1)
> It seems like, when you pass the boot=live kernel parameter,
> the init file pickups the BOOT=live, and executes
> . /scripts/live
> which calls         /lib/live/boot.sh ${@}
> The /lib/live/boot.sh script itself just sources .sh files in
> /lib/live/boot/ but doesn't execute anything.
> I suppose that direct calling /lib/live/boot.sh in /scripts/live is the issue,
> because when you call script directly it does not return the
> environment variables, and so
> mountroot wasn't defined in /init file.
> when I changed /scripts/live to just source the /lib/live/boot.sh
> file, by calling it with dot, like
> . /lib/live/boot.sh ${@}
> I was able to boot, but it looks like no boot parameters applied,
> excepts of fromiso,
> like hostname or username wasn't changed,
> and system asked for login and hostname was localhost.localdomain.
> Sorry if something is unclear, tried my best

Did you get a response? My builds (wheezy i386 on i386) are building,
then failing when booting and dropping to initramfs. Same error
(mountroot is not found):

lb config \
--binary-images hdd \
--bootappend-live "hostname=foo username=bar persistence
locales=en_GB.UTF-8 keyboard-layouts=gb" \
--package-lists "standard-x11" \
--archives live.debian.net \
--apt-recommends false \
--mirror-bootstrap "http://foo:3142/ftp.uk.debian.org/debian/";

It all builds the binary.img fine apart from the warning below about:

update-initramfs: Generating /boot/initrd.img-3.2.0-2-686-pae
df: Warning: cannot read table of mounted file systems: No such file
or directory
live-boot:W: live-boot-initramfs-tools (backend) installed without live-boot,
W: this initramfs will *NOT* have live support.

I think Daniel fixed live-boot for that in git, but I got the same
error building from the latest live-build source and same result.

lb --version
live-build, version 3.0~a49-1

I've also tried it with live-build from git (marked as a50, but I
think the VERSION file still states a49).

I've also tried a vanilla build

lb config; lb build

This also fails when booted with mountroot error. Have tried from both
kvm and dd'ing to a standard USB stick. Can anyone else verify if it
is just us with the problem and if we can do anything to help
ourselves? I'm happy to supply a build.log or any other information as



Reply to: