[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Australian mirrors result in "Encountered a section with no Package: header"

I'm trying to build a live Wheezy system, and since I live in
Australia I'd like to use an Australian mirror. Unfortunately, every
time I've tried to use one over the last ten days, my build has
failed. Mirrors I've tried include the official ftp.au.debian.org,
ftp.netspace.net.au, mirror.aarnet.edu.au and mirror.waia.asn.au (the
mirror is used for the bootstrap, chroot, and binary stages). It
definitely works with the US mirror.

The end of the build log for the failed builds is:

[2012-03-06 18:28:33] lb_chroot_archives chroot install
P: Configuring file /etc/apt/sources.list
Get:1 http://ftp.au.debian.org wheezy InRelease [179 kB]
Get:2 http://ftp.au.debian.org wheezy/main amd64 Packages/DiffIndex [2177 B]
Get:3 http://ftp.au.debian.org wheezy/contrib amd64 Packages/DiffIndex [2023 B]
Get:4 http://ftp.au.debian.org wheezy/non-free amd64 Packages/DiffIndex [2023 B]
Ign http://ftp.au.debian.org wheezy/contrib TranslationIndex
Get:5 http://ftp.au.debian.org wheezy/main TranslationIndex [2154 B]
Ign http://ftp.au.debian.org wheezy/non-free TranslationIndex
Get:6 http://ftp.au.debian.org wheezy/main Sources [7335 kB]
Get:7 http://ftp.au.debian.org wheezy/contrib Sources [59.0 kB]
Get:8 http://ftp.au.debian.org wheezy/non-free Sources [113 kB]
Get:9 http://ftp.au.debian.org wheezy/contrib Translation-en [35.0 kB]
Get:10 http://ftp.au.debian.org wheezy/main Translation-en [3754 kB]
Get:11 http://ftp.au.debian.org wheezy/non-free Translation-en [63.1 kB]
Fetched 11.5 MB in 2min 1s (94.8 kB/s)
W: Failed to fetch
 Encountered a section with no Package: header

W: Failed to fetch
 Encountered a section with no Package: header

W: Failed to fetch
 Encountered a section with no Package: header

E: Some index files failed to download. They have been ignored, or old
ones used instead.
P: Begin unmounting filesystems...
P: Saving caches...
Reading package lists...
Building dependency tree...

Normally I'd just try again later, but it's been more than a week and
I'm starting to wonder if it's nothing to do with the archives
themselves, but with my build machine. I tried "sudo lb clean --purge"
and "sudo rm /var/lib/apt/lists/* -vf" (on the build machine... I
did't really expect that to help live-build, but worth a shot).

Is it likely to be a local problem, or is there really something wrong
with all of the Australian mirrors?

— Jason

Reply to: