[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#653310: live-magic: Clicking the "Apply" button does not trigger any action.



Package: live-magic
Version: 1.14
Severity: grave
Justification: renders package unusable

Dear Maintainer,

   * What exactly did you do (or not do) that was effective (or
     ineffective)?

Run "live-magic".
Select the following options (not sure it really matters, though) :
Image type : "Standard Debian GNU/Linux image"
Distribution : "Unstable (sid)"
Media type : "USB/HDD image"
Mirror : "http://ftp.fr.debian.org/debian/";
Architecture : "amd64"
Debian installer : "no"
Locale and keyboard layout : "en_US.UTF-8" and "USA (US)"
Build folder : "/home/cyril/debianlive"
Click "Apply"

   * What was the outcome of this action?
Nothing happens in the UI. The following error is displayed in my terminal :

* cd "/home/cyril/debianlive"; lb config --ignore-system-defaults --packages-
lists='standard' --mirror-bootstrap='http://ftp.fr.debian.org/debian/'
--language='en' --cache-packages='false' --bootappend-live='locale=en_US.UTF-8
keyb=us' --cache-stages='none' --architecture='amd64' --debian-
installer='false' --distribution='sid' --binary-images='usb-hdd'
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.7/LiveMagic/controllers/wizard.py", line 50,
in on_wizard_apply
    self.model = Config(build_dir, **data)
  File "/usr/lib/pymodules/python2.7/DebianLive/__init__.py", line 55, in
__init__
    raise IOError, out
IOError: lb config: unrecognized option '--packages-lists=standard'
lb config: unrecognized option '--language=en'

   * What outcome did you expect instead?
live-magic should proceed and build a Debian live image.



-- System Information:
Debian Release: wheezy/sid
  APT prefers stable-updates
  APT policy: (500, 'stable-updates'), (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages live-magic depends on:
ii  gksu            2.0.2-6
ii  live-build      3.0~a40-1
ii  python          2.7.2-9
ii  python-glade2   2.24.0-2
ii  python-gtk2     2.24.0-2
ii  python-support  1.0.14
ii  python-vte      1:0.28.2-4
ii  xdg-utils       1.1.0~rc1+git20111210-3

Versions of packages live-magic recommends:
ii  cdebootstrap  0.5.8+b1

live-magic suggests no packages.

-- no debconf information



Reply to: