[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

building squeeze on wheezy (using live 3.x)


Who wants to build a Squeeze live image by using live 3.x (the current version on wheezy) will triggers this bug : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622838

A workaround is to using apt pinning to use wheezy packages by adding a config/chroot_apt/preferences file :

Explanation: Squeeze provides an incomplete package so we use the one from wheezy
Package: syslinux-themes-debian-squeeze
Pin: release n=wheezy
Pin-Priority: 1000

I defined squeeze as the default distribution in config/chroot_apt/apt.conf (I m not sure if it s required or not) :

APT::Install-Recommends    "0";
APT::Install-Suggests     "0";
APT::Default-Release    "squeeze";

Reply to: