[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#630043: use dpkg --force-unsafe-io if available



On Sat, Jun 11, 2011 at 01:36:18PM +0200, Daniel Baumann wrote:
> On 06/10/2011 05:02 PM, Colin Watson wrote:
> >The --force-unsafe-io option was introduced in dpkg 1.15.8.6 (see
> >#584254).  It's useful for cases where it doesn't matter if unpacked
> >files are properly preserved across power failures, and live image
> >builds were one of the main use cases we were thinking about: in the
> >case of an interrupted live image build, you'd just 'lb clean' and start
> >again.  Thus, it seems sensible to use it across the board if it's
> >available.  Patch attached.
> 
> applied but without the version check, we're supporting >=squeeze
> only anyway.

That will break Ubuntu maverick and earlier; not that I'm going to be
using live-build for those, but I believe Cody Somerville does.

-- 
Colin Watson                                       [cjwatson@ubuntu.com]



Reply to: