[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: uncompression error at boot

On 26/04/11 05:40 PM, grant centauri wrote:
> I ran lb config with a bunch of options, and tried lb build.

Care to share what those options were?

> It failed
> due to a hash sum mismatch near the very end of the build.

It helps if you give us exact error messages in context.

> So, I ran lb
> clean and then lb build again, which finished successfully this time.

Sounds strange. You sure there were no errors in that build? Do you log
your builds? If not, you should (the auto scripts would take care of
this for you) and examine the log of each build to ensure you have no
errors before asking for help.

> I
> dd'ed the iso onto a USB drive, and tried booting but ended with an
> "uncompression error, system halt" which also happened with a failsafe
> boot as well.  I've had the same problem after reconfiguring an image in
> the same directory and building it again (perhaps this has something do
> do with not using the auto scripts?  i don't quite understand them). 

Well, no, I don't think auto scripts would prevent these failures, but I
think they might help you keep things easily reproducible and keep logs
of each build.

They're really not that hard to understand. Each auto script is a
wrapper for the corresponding 'lb' command. They are automatically
invoked when you issue that command. So, 'auto/config' is called when
you 'lb config' and it, in turn, calls the real 'lb config' (with
'noauto' this time, to ensure we don't infinitely recurse :)

> Any help would be welcome, I've been reading the manual but am unclear
> on the process of reconfiguration and rebuilding.  I have only been
> successful if I build an image from scratch in one go. 

'lb clean' followed by 'lb build' should be sufficient to start fresh.
If you're getting an error that goes away after a rebuild, I think you
might consider external factors in your build system: corrupt
filesystem? failing disk? the md5sum error in the first attempt and the
"uncompression error" in the second particularly make me think it might
be one of these possible causes.


Reply to: