[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#612913: unionfs-fuse root does not work

Package: live-boot
Severity: normal

I tried a few more things with unionfs-fuse.

First I tried break=init or init=bin/sh.

At both points the system still appears functional but initscripts fail
after that. I also found that if I type

touch test
exec /sbin/init

at the prompt of the "init" shell the system boots but it does not if I
script this from break=bottom or type only exec /sbin/init. This looks
like a race somewhere.

When the initscripts fail complaining about readonly filesystem I can
still log in after some minuts if my root account is enabled in the
image. fuse is still running and the union is actually writable but some
files visible in /live/cow are not in / and the other way around.

Looks like unionfs-fuse cannot take the beating from parallel
initscripts, it's just too flaky. Not much debian-live can do about

-- System Information:
Debian Release: 6.0
  APT prefers stable
  APT policy: (990, 'stable'), (500, 'testing'), (400, 'unstable'), (395, 'experimental'), (300, 'stable-i386'), (300, 'oldstable'), (280, 'testing-i386'), (270, 'unstable-i386'), (150, 'experimental-i386'), (65, 'oldstable-i386')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.36-r600fence-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Reply to: