[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#600283: marked as done (live-build: binary.img not created, incorrect sources.list)

Your message dated Fri, 12 Nov 2010 19:18:36 +0100
with message-id <1289585916.5272.3.camel@meh>
and subject line Re: Bug#600283: live-build: binary.img not created, incorrect sources.list
has caused the Debian Bug report #600283,
regarding live-build: binary.img not created, incorrect sources.list
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

600283: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=600283
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: live-build
Version: 2.0.2-1
Severity: serious
Justification: images don’t build without network access

I define a mirror for the bootstrap phase. A mirror (the same) for the
chroot phase. A mirror (still the same) for the binary phase. I make a
configuration for a usb-hdd build.

But in the end, live-build fails silently. The script finishes, and I
don’t get any binary.img.

Removing .stage/binary* and retrying gives another error message:

# lb binary
P: Begin building root filesystem image...
Reading package lists... Done
Building dependency tree... Done
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 114 kB of archives.
After this operation, 295 kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
E: There are problems and -y was used without --force-yes
P: Begin unmounting filesystems...

In chroot/etc/apt/sources.list, there is only one line:
	deb http://ftp.us.debian.org/debian/ squeeze main
Since ftp.us is not reachable from the machine where it is building
(remember, I set a specific mirror precisely because of that), this
explains the error.

>From here, I tried a bit of voodoo: replaced the sources.list by hand,
run apt-get update in the chroot. No more luck, it still fails silently,
and AFAICT I’m not using a specific filesystem that specifically trashes
files named binary.img. 

Running “lb binary” twice will even overwrite the sources.list again
(seriously? isn’t the contents of the chroot supposed to be fixed after
the chroot phase?)

No more luck with lb binary_usb:

# lb binary_usb
P: Mounting /dev/loop1 with offset 0
Warning: The resulting partition is not properly aligned for best performance.
1+0 records in
1+0 records out
440 bytes (440 B) copied, 0.000518781 s, 848 kB/s
P: Mounting /dev/loop1 with offset 512
mkfs.vfat 3.0.9 (31 Jan 2010)
Loop device does not match a floppy size, using default hd params
Can't open /proc/13761/fd/3: No such file or directory
Cannot initialize 'S:'
Bad target s:/ldlinux.sys
syslinux: failed to create ldlinux.sys

So, should I prepare for sacrificing a chicken now?

I’m seriously sick of the whole of live-build being changed in each
version. I used to be able to build working images with earlier versions
of 2.0. We’re supposed to be in a *deep freeze*, and not only did the
configuration format change again, but now it’s not even possible to do
the simplest things anymore.

: :' :     “You would need to ask a lawyer if you don't know
`. `'       that a handshake of course makes a valid contract.”
  `-        --  J???rg Schilling

--- End Message ---
--- Begin Message ---
I can no longer reproduce this bug when starting from a fresh chroot
with the latest live-build version, so you can consider it fixed.

Still, I reiterate my concerns about configuration files not being
manageable in version control, requiring to maintain scripts in auto/
instead - scripts that are not able to set all available variables
anyway. Live-build is a great tool, but I think it would gain a lot from
a simpler configuration system.

: :' :     “You would need to ask a lawyer if you don't know
`. `'       that a handshake of course makes a valid contract.”
  `-        --  J???rg Schilling

--- End Message ---

Reply to: