[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian Live image failed to boot with custom kernel

I'm trying to boot a debian live distro with custom kernel from usb but i receive the follow error and the boot process stops:

	This Debian Live image failed to boot.

	live-initramfs will now start a shell. The error message was:
	FATAL: Could not load /lib/modules/2.6.26-custom/modules.dep: No such file or directory
	FATAL: Could not load /lib/modules/2.6.26-custom/modules.dep: No such file or directory
	Unable to find a medium containing a live file system

	BusyBox v1.10.2 (Debian 1:1.10.2-2) built-in shell (ash)

	/bin/sh: can't access tty: job control turned off

I can't access to /live.log file because I can't type command here.

Initially I used debian live distro with its kernel 2.6.26 to boot on usb and all works fine.

Afterwards I download debian kernel 2.6.26 and compile it with the config find in the distro, I use this command to compile the kernel:
fakeroot make-kpkg --added-modules lzma,aufs,squashfs --append-to-version -custom --revision=1 kernel_image --initrd

The lzma, aufs, squashfs modules are place in /usr/src/modules directory.

I modified /root/live/config/chroot file with

It generate a .dep package, after I run:
copy linux-image-2.6.26-custom_1_i386.deb /root/live/config/chroot_local-packages/
lh config -b usb-hdd
lh build
dd if=binary.img of=/dev/sdb
My live.cfg is:
label live
	menu label custom
	kernel /live/vmlinux-2.6.26-custom
	append initrd=/live/initrd.img-2.6.26-custom boot=live locale=en vga=791 noxautologin noautologin quickreboot

where under /root/live/binary/live directory there are the following files:

I try also to compile external kernel modules in different manner with:
fakeroot make-kpkg --append-to-version -custom --revision=1 kernel_image --initrd modues
m-a -k /usr/src/linux-source-2.6.26 build lzma
m-a -k /usr/src/linux-source-2.6.26 build aufs
m-a -k /usr/src/linux-source-2.6.26 build squashfs
mv /usr/src/*.deb /root/live/config/chroot_local-packages/

but I received the same error.

I'm using live-helper 2.0~a11-1 version.

Could you help me?


Reply to: